Saturday, January 24, 2009

Wacom Intuos Pen GP300E Disassembly

I went to use my Intuos tablet and found out that my Wacom pen is f'd up, it acts like it is always in the "clicked" position, the tip sensitivity still worked but it couldn't detect if the tip was being "clicked". The utility said that Button 1 was constantly ON, and only when I rapped it on the side would it flicker off just to come back on. So... $50 bucks for a replacement? I might as well try to fix it myself...

Sooo I wrangled and pushed and pried to no avail, then... I bent more and more and more and... Snap!

Damn, there was a long circuit board in there that snapped with the plastic housing.

Anyway, this is how it should have slid apart, maybe if you pushed on the eraser end to help a bit it may come out easier. I really did try pulling the thing apart, just not hard enough I guess.

Update from commenter [alcomposer]:  "When I took mine apart, I simply held it with both hands, and pushed my thumbs together and slowly pulled it apart."



My hope is that somebody will stumble on this page if they are trying to get their stylus pen apart and do it the right way.



Update from commenter [Chad von Nau]:

Thanks to everyone on here who posted tips, I wouldn't have been able to take my pen apart otherwise. Here's what it looks like disassembled with the circuit board in one piece:


I had the same problem where the pen was always registering a click. Thwacking it on my palm would fix it temporarily and eraser side still worked fine, so I knew it had to be something with the pen. It took me a few hours to get it apart. I started with full strength two handed pulling. I also tried pressing my thumbs against each other like alcomposer suggested. What seemed to work best was moderate strength pulling while _gently_ rocking back and forth. While I was doing this, I kept hearing worrisome clicking/cracking noises, but it was OK in the end.

Once I got it open, I pulled the nib out and gently took the magnet out of its cradle. I swabbed the inside with rubbing alcohol on the tip of a paper towel. Then I put the nib in without the magnet and spun it around so that its receiver assembly also spun around. There was less resistance after a few rotations, so I think I was able to unstick something with that.

Putting it back together was easy enough except for the eraser spring. You can see how small it is in the top right of the photo. Searching for that on my carpeted floor added an hour to the process.

The pen seems OK now. If the problem returns, I have one last idea. The pen has two nib receiver assemblies, one for the pen and one for the eraser. They are the yellow parts in the photo. I suspect that swapping these would move the perma-click problem to the eraser end, which is less critical for me. I was unable to get them out when I tried this time, and they have what look like rather breakable plastic clips, so I hope I don't have to try it.

---

So my first repair attempt (see previous comment) was unsuccessful. The pen reverted to it's perma-click behavior within a day. I made another repair attempt, this time I swapped the parts that I'm calling the receiver assemblies. Opening the pen only took a minute this time, a combination of confidence and loosening caused by the original repair.

Swapping the receiver assemblies wasn't as difficult as I thought, the trick was using point tipped tweezers (I used this one http://www.amazon.com/dp/B0006SIPIK). I started with the pen tip assembly first. If you place the tweezer tips in the corners where the ends of white clip meet the lip of the yellow receiver assembly, farthest from the circuit board, you can apply pressure outward and up which will release one side of the clip. Repeat this on the rear side of the same clip. Once you release the clip, the yellow assembly should slide out easily. Underneath the assembly, there are three small disks. The top one is rubbery and will probably have an inward indentation if your pen is as used as mine. The middle disk is a washer made out some kind of brown mylar material. The bottom disk is thick and metallic. It has a smaller inset piece of metal on it's bottom side. Carefully remove these and place them aside. It's handy to have a Q-tip around and this point so you can clean off any debris from the disks and so you can move them around without getting your finger oils on them. I repeated this process on the eraser side. Here's a photo of everything disassembled:


Finally, each piece I removed from the pen tip side was installed on the eraser side, and vice versa, being careful to orient the disks in the way that they had originally been installed. Put the pen back together and done.

So far so good. My hope is that whatever wear that causes the perma-click behavior is now isolated to the eraser side. I will report back if it goes south again.
---

Thanks for letting me copy your info to the main portion of the post Chad, stuff seems to live longer on the internet when it's in a few different places :)

w580i video player fast forward

I posted this over at http://www.topsony.com/forum/mobile-phones-f4/w580i-video-controls-t14025.html


Since I had this question too I figure it's good to spread the answer far and wide for teh good of the intarnets.

To Fast Forward video on the w580i using the included video player in portrait mode just hold down right on the directional pad, the button that has >> on it, hold down left (<<) to rewind. You can see the time go by in the bar at the top and let go when you get to the correct minute:second.

When you are in landscape mode you hold down the down button to fast forward and you hold down the up button to rewind..

Sony assumes you have turned the phone on it's side when you use landscape mode, that's why the FF button changes. Also, you don't have the nice bar to indicate the time position as you are fast forwarding so you have to just guess when to stop holding the button or switch back to portrait mode to fast forward or rewind.


w580i video player controls FF RW fast forward

all the entries